summaryrefslogtreecommitdiff
path: root/app-benchmarks/contest
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/contest')
-rw-r--r--app-benchmarks/contest/Manifest1
-rw-r--r--app-benchmarks/contest/contest-0.61.ebuild38
-rw-r--r--app-benchmarks/contest/files/contest-fortify_sources.patch11
-rw-r--r--app-benchmarks/contest/metadata.xml8
4 files changed, 58 insertions, 0 deletions
diff --git a/app-benchmarks/contest/Manifest b/app-benchmarks/contest/Manifest
new file mode 100644
index 00000000000..d179d78e26e
--- /dev/null
+++ b/app-benchmarks/contest/Manifest
@@ -0,0 +1 @@
+DIST contest-0.61.tar.gz 33676 SHA256 f35f89cc46c9a826c218e305e8580bfce7a4a8cb05392792ac623a410ecbfdac SHA512 94da72227af07909fe4bcbbbe303cc3a04bf871a7e2f2c133b2ac7974250528e7cfbb40ae98f80f392c8b65b37f42812a46c11c77ba985702a383eda1d3682f2 WHIRLPOOL 762d56bc71a84ede16da78b757449ad226a40b64413ebc81aa7c29f40ced2dd223ae09d4eb7fba50e2d8d81b34cf6a0168afd367ef85da1e1265f6b272473423
diff --git a/app-benchmarks/contest/contest-0.61.ebuild b/app-benchmarks/contest/contest-0.61.ebuild
new file mode 100644
index 00000000000..149c9dbb4b9
--- /dev/null
+++ b/app-benchmarks/contest/contest-0.61.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Test system responsiveness to compare different kernels"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/"
+SRC_URI="http://members.optusnet.com.au/ckolivas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=app-benchmarks/dbench-2.0"
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/contest-fortify_sources.patch"
+
+ #Removing -g
+ sed -i "s:-g::" Makefile
+ #Adding our cflags
+ sed -i "s:-O2:${CFLAGS} ${LDFLAGS}:" Makefile
+ sed -i -e "/^CC/s/gcc/$(tc-getCC)/" Makefile
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin contest || die
+ doman contest.1
+ dodoc README
+}
diff --git a/app-benchmarks/contest/files/contest-fortify_sources.patch b/app-benchmarks/contest/files/contest-fortify_sources.patch
new file mode 100644
index 00000000000..cb2e6d6dd63
--- /dev/null
+++ b/app-benchmarks/contest/files/contest-fortify_sources.patch
@@ -0,0 +1,11 @@
+--- bmark.c 2009-02-27 23:13:44.000000000 +0000
++++ bmark.c 2009-02-27 23:12:44.000000000 +0000
+@@ -47,7 +47,7 @@
+ }
+ /* child */
+
+- if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC))==-1){
++ if((tmpfd=open(TMP_FILE, O_RDWR|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR))==-1){
+ printsys("Could not open temporary file\n");
+ }
+ if(dup2(tmpfd, TMP_FD)==-1){
diff --git a/app-benchmarks/contest/metadata.xml b/app-benchmarks/contest/metadata.xml
new file mode 100644
index 00000000000..59e2b8f78cb
--- /dev/null
+++ b/app-benchmarks/contest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>