summaryrefslogtreecommitdiff
path: root/app-cdr/recorder
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/recorder')
-rw-r--r--app-cdr/recorder/Manifest1
-rw-r--r--app-cdr/recorder/metadata.xml14
-rw-r--r--app-cdr/recorder/recorder-1.4.5-r1.ebuild61
-rw-r--r--app-cdr/recorder/recorder-1.4.5.ebuild66
4 files changed, 142 insertions, 0 deletions
diff --git a/app-cdr/recorder/Manifest b/app-cdr/recorder/Manifest
new file mode 100644
index 00000000000..890881b00e2
--- /dev/null
+++ b/app-cdr/recorder/Manifest
@@ -0,0 +1 @@
+DIST recorder-1.4.5.tar.bz2 32037 SHA256 9bef2520c81c7afaf565080b9e157c8fa454c74e2ab821dc79b899de0aeba010 SHA512 b923241fe41a326caf21668f6f7a2e461c98049846163dcbdfad42e3c8fe9a3d33c48066708b2df426da26bfa325a535a3494397a2fe3e4b94820c7e4b8d88a8 WHIRLPOOL 11fea10982a7aaabefb03144751043632eb8987549ec43521609e18b3dc29538fe231c089bca0d7e2bd0272e00bda1f47be682ceb402dafb78e2b47d2912e648
diff --git a/app-cdr/recorder/metadata.xml b/app-cdr/recorder/metadata.xml
new file mode 100644
index 00000000000..71fa8c59867
--- /dev/null
+++ b/app-cdr/recorder/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+ <longdescription lang="en">
+ Recorder is a graphical frontend of cdrecord/cdrtools, cdrdao, mkisofs
+ and growisofs. It aims to be simple and easy to use, free of large
+ configurations and useless options, following the KISS principle and
+ offering a disc burning of quality, nothing more. You can burn data
+ (CD/DVD), audio (CD), video (DVD, VCD and SVCD), iso images (CD/DVD),
+ create iso images to burn later and check integrity of burned files
+ with md5sum.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-cdr/recorder/recorder-1.4.5-r1.ebuild b/app-cdr/recorder/recorder-1.4.5-r1.ebuild
new file mode 100644
index 00000000000..5e2b36728c7
--- /dev/null
+++ b/app-cdr/recorder/recorder-1.4.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime python-single-r1
+
+DESCRIPTION="A simple GTK+ disc burner"
+HOMEPAGE="http://code.google.com/p/recorder/"
+SRC_URI="http://recorder.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dvdr mp3 nls ogg vcd"
+
+LANGS="ar cs es fr it nl pl pt_BR ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2[${PYTHON_USEDEP}]
+ sys-apps/coreutils
+ virtual/cdrtools
+ dvdr? ( app-cdr/dvd+rw-tools )
+ mp3? ( media-sound/mpg123 )
+ ogg? ( media-sound/vorbis-tools )
+ vcd? (
+ app-cdr/cdrdao
+ media-video/vcdimager
+ )"
+
+DOCS=( CHANGELOG TRANSLATORS )
+
+src_prepare() {
+ python_fix_shebang recorder
+
+ local MY_NLS=""
+ if use nls; then
+ for ling in ${LINGUAS}; do
+ if has $ling ${LANGS}; then
+ MY_NLS="${MY_NLS} ${ling}"
+ fi
+ done
+ fi
+
+ sed -i -e "s:ar cs es fr pt_BR ru it nl:${MY_NLS}:" Makefile || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-cdr/recorder/recorder-1.4.5.ebuild b/app-cdr/recorder/recorder-1.4.5.ebuild
new file mode 100644
index 00000000000..467b5d0ad88
--- /dev/null
+++ b/app-cdr/recorder/recorder-1.4.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+
+inherit fdo-mime python
+
+DESCRIPTION="A simple GTK+ disc burner"
+HOMEPAGE="http://code.google.com/p/recorder/"
+SRC_URI="http://recorder.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dvdr mp3 nls ogg vcd"
+
+LANGS="ar cs es fr it nl pl pt_BR ru sv"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ sys-apps/coreutils
+ virtual/cdrtools
+ dvdr? ( app-cdr/dvd+rw-tools )
+ mp3? ( media-sound/mpg123 )
+ ogg? ( media-sound/vorbis-tools )
+ vcd? (
+ app-cdr/cdrdao
+ media-video/vcdimager
+ )"
+
+DOCS="CHANGELOG TRANSLATORS"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 recorder
+
+ local MY_NLS=""
+ if use nls; then
+ for ling in ${LINGUAS}; do
+ if has $ling ${LANGS}; then
+ MY_NLS="${MY_NLS} ${ling}"
+ fi
+ done
+ fi
+
+ sed -i -e "s:ar cs es fr pt_BR ru it nl:${MY_NLS}:" Makefile || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}