summaryrefslogtreecommitdiff
path: root/app-crypt/qca-cyrus-sasl
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca-cyrus-sasl')
-rw-r--r--app-crypt/qca-cyrus-sasl/Manifest1
-rw-r--r--app-crypt/qca-cyrus-sasl/metadata.xml7
-rw-r--r--app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild36
3 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/qca-cyrus-sasl/Manifest b/app-crypt/qca-cyrus-sasl/Manifest
new file mode 100644
index 00000000000..99ae337239b
--- /dev/null
+++ b/app-crypt/qca-cyrus-sasl/Manifest
@@ -0,0 +1 @@
+DIST qca-cyrus-sasl-2.0.0-beta3.tar.bz2 24075 SHA256 d4370c238808811a0b5e9367069296a6330b169f091c5ea5d4d18eedb6bb11b9 SHA512 933ac335aa04f7f9643c89ff94005c465c5a0c8cda494fa4849d0c8709d7d7a94bcc3f0dd1f97a940e73cd4a088e027bed63598cd95cebb13984e45f479ffa0a WHIRLPOOL a4840df54f42bbe8d3d364fda57df8297323f33c57afc45377e4c6dd758d2a6e4398333c4e9196c0ff25a56ca939e8ee11cf91b00daab341f6ac1d8c358e9be5
diff --git a/app-crypt/qca-cyrus-sasl/metadata.xml b/app-crypt/qca-cyrus-sasl/metadata.xml
new file mode 100644
index 00000000000..1bbdcda23f1
--- /dev/null
+++ b/app-crypt/qca-cyrus-sasl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<herd>crypto</herd>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild b/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
new file mode 100644
index 00000000000..1b86256ba60
--- /dev/null
+++ b/app-crypt/qca-cyrus-sasl/qca-cyrus-sasl-2.0.0_beta3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils qt4-r2
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="SASL plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~ia64 ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
+ dev-libs/cyrus-sasl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # cannot use econf because of non-standard configure script
+ ./configure --qtdir=/usr --no-separate-debug-info \
+ $(use debug && echo "--debug" || echo "--release") || die
+
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die
+}