summaryrefslogtreecommitdiff
path: root/app-emacs/dash/dash-2.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/dash/dash-2.14.1.ebuild')
-rw-r--r--app-emacs/dash/dash-2.14.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.14.1.ebuild b/app-emacs/dash/dash-2.14.1.ebuild
new file mode 100644
index 00000000000..da2a16d87b0
--- /dev/null
+++ b/app-emacs/dash/dash-2.14.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="dash.texi"
+DOCS="README.md"
+
+src_test() {
+ ./run-tests.sh || die
+}