summaryrefslogtreecommitdiff
path: root/app-emacs/thumbs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/thumbs')
-rw-r--r--app-emacs/thumbs/Manifest1
-rw-r--r--app-emacs/thumbs/files/50thumbs-gentoo.el11
-rw-r--r--app-emacs/thumbs/metadata.xml5
-rw-r--r--app-emacs/thumbs/thumbs-2.0.ebuild20
4 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/thumbs/Manifest b/app-emacs/thumbs/Manifest
new file mode 100644
index 00000000000..d92efde82d6
--- /dev/null
+++ b/app-emacs/thumbs/Manifest
@@ -0,0 +1 @@
+DIST thumbs-2.0.el.bz2 6521 SHA256 e7f788f4e19c21b535024cdc49185e922fe91e39f7502486cca09a0125bb6935 SHA512 d4bca861ed5db620a2319659e255bef14241a68067be994402d2d36bb7fe34ab5a22b6b76dea5631aa5288d03caadb3a8163a8ecf439144d8d50cc410cfe078d WHIRLPOOL 3fd85cff14a9e40cf657994c9d44b337ad525dcf13ddede1a2d9262fe249ccfc126d702ee67b2c809bf1a25dc7764d6bc2f447b168abea1e967c0d595bd48573
diff --git a/app-emacs/thumbs/files/50thumbs-gentoo.el b/app-emacs/thumbs/files/50thumbs-gentoo.el
new file mode 100644
index 00000000000..12627d30c75
--- /dev/null
+++ b/app-emacs/thumbs/files/50thumbs-gentoo.el
@@ -0,0 +1,11 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'thumbs-find-thumb "thumbs" "Display the thumbnail for IMG." t)
+(autoload 'thumbs-show-all-from-dir "thumbs"
+ "Make a preview buffer for all images in DIR." t)
+(autoload 'thumbs-dired-show-marked "thumbs"
+ "In Dired, make a thumbs buffer with all marked files." t)
+(autoload 'thumbs-dired-show-all "thumbs"
+ "In dired, make a thumbs buffer with all files in current directory." t)
+(defalias 'thumbs 'thumbs-show-all-from-dir)
+(autoload 'thumbs-dired-setroot "thumbs"
+ "In dired, Call the setroot program on the image at point." t)
diff --git a/app-emacs/thumbs/metadata.xml b/app-emacs/thumbs/metadata.xml
new file mode 100644
index 00000000000..bc306fe5822
--- /dev/null
+++ b/app-emacs/thumbs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/thumbs/thumbs-2.0.ebuild b/app-emacs/thumbs/thumbs-2.0.ebuild
new file mode 100644
index 00000000000..d5998aefa85
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="http://www.emacswiki.org/emacs/ThumbsMode"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+SITEFILE="50${PN}-gentoo.el"