summaryrefslogtreecommitdiff
path: root/app-emulation/kompose/kompose-0.1.2_p20161207.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/kompose/kompose-0.1.2_p20161207.ebuild')
-rw-r--r--app-emulation/kompose/kompose-0.1.2_p20161207.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/app-emulation/kompose/kompose-0.1.2_p20161207.ebuild b/app-emulation/kompose/kompose-0.1.2_p20161207.ebuild
deleted file mode 100644
index 7472d638f3c..00000000000
--- a/app-emulation/kompose/kompose-0.1.2_p20161207.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/kubernetes-incubator/kompose/..."
-EGIT_COMMIT="04a3131834cddfb1af42b63b21641fbbf84a4a9d"
-ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Tool to move from docker-compose to Kubernetes"
-HOMEPAGE="https://github.com/kubernetes-incubator/kompose"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0/${PVR}"
-IUSE="hardened"
-
-src_prepare() {
- default
- sed -i -e "s/HEAD/${EGIT_COMMIT:0:7}/" src/${EGO_PN%/*}/version/version.go || die
-}
-
-src_compile() {
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
- GOPATH="${S}" go build -o bin/kompose src/${EGO_PN%/*}/main.go || die
-}
-
-src_install() {
- dobin bin/*
- dodoc -r src/${EGO_PN%/*}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
-}