summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/qemu-2.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu/qemu-2.4.0-r1.ebuild')
-rw-r--r--app-emulation/qemu/qemu-2.4.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/qemu/qemu-2.4.0-r1.ebuild b/app-emulation/qemu/qemu-2.4.0-r1.ebuild
index ba77ef86b3f..8d50bd3e7b8 100644
--- a/app-emulation/qemu/qemu-2.4.0-r1.ebuild
+++ b/app-emulation/qemu/qemu-2.4.0-r1.ebuild
@@ -275,8 +275,9 @@ check_targets() {
pushd "${S}"/default-configs >/dev/null || die
- detected=$(echo $(printf '%s\n' *-${mak}.mak | sed "s:-${mak}.mak::" | sort -u))
- sorted=$(echo $(printf '%s\n' ${!var} | sort -u))
+ # Force C locale until glibc is updated. #564936
+ detected=$(echo $(printf '%s\n' *-${mak}.mak | sed "s:-${mak}.mak::" | LC_COLLATE=C sort -u))
+ sorted=$(echo $(printf '%s\n' ${!var} | LC_COLLATE=C sort -u))
if [[ ${sorted} != "${detected}" ]] ; then
eerror "The ebuild needs to be kept in sync."
eerror "${var}: ${sorted}"