summaryrefslogtreecommitdiff
path: root/app-emulation/wine/wine-1.7.16-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.7.16-r1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.7.16-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.7.16-r1.ebuild b/app-emulation/wine/wine-1.7.16-r1.ebuild
index 8f144873284..23dbb345f6b 100644
--- a/app-emulation/wine/wine-1.7.16-r1.ebuild
+++ b/app-emulation/wine/wine-1.7.16-r1.ebuild
@@ -146,8 +146,10 @@ wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
# bug #549768
- if [[ $(gcc-major-version) = 5 ]]; then
- eerror "You need gcc-4.x to build wine; see https://bugs.gentoo.org/549768"
+ if use abi_x86_64 && [[ $(gcc-major-version) = 5 ]]; then
+ eerror "64-bit wine cannot be built with gcc-5.1 or 5.2 due to compiler bugs;"
+ eerror "you may use gcc-config to select an older compiler version."
+ eerror "See https://bugs.gentoo.org/549768"
eerror
return 1
fi