summaryrefslogtreecommitdiff
path: root/app-emulation/wine/wine-1.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.8-r1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.8-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.8-r1.ebuild b/app-emulation/wine/wine-1.8-r1.ebuild
index e074f929d4e..bdb29eb7b5d 100644
--- a/app-emulation/wine/wine-1.8-r1.ebuild
+++ b/app-emulation/wine/wine-1.8-r1.ebuild
@@ -189,8 +189,13 @@ wine_build_environment_check() {
fi
fi
- if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
- eerror "You need gcc-4.4+ to build 64-bit wine"
+ if use abi_x86_64 && einfo "Checking for builtin_ms_va_list ..." && \
+ ( $(tc-getCC) -O2 "${FILESDIR}"/builtin_ms_va_list.c -o "${T}"/builtin_ms_va_list >/dev/null 2>&1) ; then
+ einfo "$(tc-getCC) supports builtin_ms_va_list, enabling 64-bit wine"
+ else
+ eerror "This version of $(tc-getCC) does not support builtin_ms_va_list, can't enable 64-bit wine"
+ eerror
+ eerror "You need gcc-4.4+ or clang 3.8+ to build 64-bit wine"
eerror
return 1
fi