summaryrefslogtreecommitdiff
path: root/app-emulation/wine/wine-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-2.1.ebuild')
-rw-r--r--app-emulation/wine/wine-2.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-emulation/wine/wine-2.1.ebuild b/app-emulation/wine/wine-2.1.ebuild
index beb9758568d..dcf9b6d9b5d 100644
--- a/app-emulation/wine/wine-2.1.ebuild
+++ b/app-emulation/wine/wine-2.1.ebuild
@@ -260,6 +260,14 @@ wine_build_environment_check() {
ewarn "Gentoo's Toolchain Team. If your ebuild fails the compiler checks in"
ewarn "the configure phase, either update your compiler or switch to <5.0 || >=5.4"
fi
+ if tc-is-gcc && [[ $(gcc-major-version) -eq 5 && $(gcc-minor-version) -eq 4 ]]; then
+ if has "-march=i686" ${CFLAGS} && ! has "-mtune=generic" ${CFLAGS}; then
+ ewarn "Compilation can hang with CFLAGS=\"-march=i686\". You can temporarily work"
+ ewarn "around this by adding \"-mtune=generic\" to your CFLAGS for wine."
+ ewarn "See package.env in man 5 portage for more information on how to do this."
+ ewarn "See https://bugs.gentoo.org/show_bug.cgi?id=613128 for more details"
+ fi
+ fi
if use abi_x86_32 && use opencl && [[ "$(eselect opencl show 2> /dev/null)" == "intel" ]]; then
eerror "You cannot build wine with USE=opencl because intel-ocl-sdk is 64-bit only."