summaryrefslogtreecommitdiff
path: root/app-misc/mosquitto
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mosquitto')
-rw-r--r--app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch b/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch
new file mode 100644
index 00000000000..12b4fc56bc3
--- /dev/null
+++ b/app-misc/mosquitto/files/mosquitto-1.4.10-conditional-tests.patch
@@ -0,0 +1,43 @@
+--- a/test/broker/Makefile 2016-06-02 22:20:22.000000000 +0100
++++ b/test/broker/Makefile 2016-07-08 14:17:33.772666865 +0100
+@@ -63,6 +63,7 @@
+ ./05-clean-session-qos1.py
+
+ 06 :
++ifeq ($(WITH_BRIDGE),yes)
+ ./06-bridge-reconnect-local-out.py
+ ./06-bridge-br2b-disconnect-qos1.py
+ ./06-bridge-br2b-disconnect-qos2.py
+@@ -70,6 +71,7 @@
+ ./06-bridge-b2br-disconnect-qos2.py
+ ./06-bridge-fail-persist-resend-qos1.py
+ ./06-bridge-fail-persist-resend-qos2.py
++endif
+
+ 07 :
+ ./07-will-qos0.py
+@@ -87,10 +89,12 @@
+ ./08-ssl-connect-cert-auth-crl.py
+ ./08-ssl-connect-identity.py
+ ./08-ssl-connect-no-identity.py
++ifeq ($(WITH_BRIDGE),yes)
+ ./08-ssl-bridge.py
+ ./08-tls-psk-pub.py
+ ./08-tls-psk-bridge.py
+ endif
++endif
+
+ 09 :
+ ./09-plugin-auth-unpwd-success.py
+--- a/test/broker/c/Makefile 2016-02-14 14:36:55.000000000 +0000
++++ b/test/broker/c/Makefile 2016-05-05 09:40:31.440608209 +0100
+@@ -13,7 +13,9 @@
+ $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
+
+ 08-tls-psk-bridge.test : 08-tls-psk-bridge.c
++ifeq ($(WITH_BRIDGE),yes)
+ $(CC) ${CFLAGS} $^ -o $@ ../../../lib/libmosquitto.so.1
++endif
+
+
+ reallyclean : clean