summaryrefslogtreecommitdiff
path: root/app-misc/when
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/when')
-rw-r--r--app-misc/when/Manifest1
-rw-r--r--app-misc/when/metadata.xml5
-rw-r--r--app-misc/when/when-1.1.33.ebuild38
3 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/when/Manifest b/app-misc/when/Manifest
new file mode 100644
index 00000000000..9a8ee2e6261
--- /dev/null
+++ b/app-misc/when/Manifest
@@ -0,0 +1 @@
+DIST when-1.1.33.tar.gz 49740 SHA256 568a49e999363a018186e03c38d116c587b332f7fcf60820f9cfc34779050ab0 SHA512 5c0934257133f75a7de984499f99f68dde5343d51051acf1b454f04dae82254c733e946a6c5ead546dc3c07cd113d938a48c95af39b80cbfc04ee6d748223c83 WHIRLPOOL 9bcbe73a4034b817fc34d302689a0b404563081163c692ee23e484fbb9ab993a90a5d468f2586e7f5327abad98f4033ebd7546255f682898e899a9fdd7629c97
diff --git a/app-misc/when/metadata.xml b/app-misc/when/metadata.xml
new file mode 100644
index 00000000000..f23b9cae159
--- /dev/null
+++ b/app-misc/when/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>
diff --git a/app-misc/when/when-1.1.33.ebuild b/app-misc/when/when-1.1.33.ebuild
new file mode 100644
index 00000000000..a4a2e3c6381
--- /dev/null
+++ b/app-misc/when/when-1.1.33.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Extremely simple personal calendar program aimed at the Unix geek who wants something minimalistic"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="http://www.lightandmatter.com/when/when.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/when_dist
+
+src_prepare() {
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile || die 'sed failed'
+}
+
+src_compile() { :; }
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when || die 'mkdir failed'
+ touch "${HOME}"/.when/{calendar,preferences} || die 'touch failed'
+ emake test
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README
+}