summaryrefslogtreecommitdiff
path: root/app-pda/libplist/libplist-1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libplist/libplist-1.12.ebuild')
-rw-r--r--app-pda/libplist/libplist-1.12.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-pda/libplist/libplist-1.12.ebuild b/app-pda/libplist/libplist-1.12.ebuild
index f674ed03a67..bc3d53f8a9d 100644
--- a/app-pda/libplist/libplist-1.12.ebuild
+++ b/app-pda/libplist/libplist-1.12.ebuild
@@ -4,7 +4,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
HOMEPAGE="http://www.libimobiledevice.org/"
@@ -29,6 +29,11 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
BUILD_DIR="${S}_build"
+src_prepare() {
+ sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
+ eautoreconf
+}
+
src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )