summaryrefslogtreecommitdiff
path: root/app-shells/mpibash/mpibash-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/mpibash/mpibash-9999.ebuild')
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
index 594ac6bc88c..76bbce43cda 100644
--- a/app-shells/mpibash/mpibash-9999.ebuild
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -3,13 +3,12 @@
EAPI=5
-inherit autotools-utils multilib
+inherit autotools multilib
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
inherit git-r3
KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
else
SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -27,16 +26,18 @@ DEPEND="virtual/mpi
sys-cluster/libcircle"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
--with-bashdir="${EPREFIX}"/usr/include/bash-plugins
- --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ default
sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
}