summaryrefslogtreecommitdiff
path: root/app-shells/psh/psh-1.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/psh/psh-1.8.1-r1.ebuild')
-rw-r--r--app-shells/psh/psh-1.8.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/psh/psh-1.8.1-r1.ebuild b/app-shells/psh/psh-1.8.1-r1.ebuild
new file mode 100644
index 00000000000..8731c596166
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="http://www.focusresearch.com/gregor/sw/psh/"
+SRC_URI="http://www.focusresearch.com/gregor/download/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+# Package warrants USE doc & examples
+IUSE="readline"
+
+DEPEND=""
+RDEPEND="readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey )"
+
+SRC_TEST="do parallel"
+myinst="SITEPREFIX=${D}/usr"
+
+src_install() {
+ perl-module_src_install
+ dodoc examples/complete-examples doc/*
+}