summaryrefslogtreecommitdiff
path: root/app-shells/yash
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/metadata.xml26
-rw-r--r--app-shells/yash/yash-2.47.ebuild33
3 files changed, 60 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
new file mode 100644
index 00000000000..44c70eccdb1
--- /dev/null
+++ b/app-shells/yash/Manifest
@@ -0,0 +1 @@
+DIST yash-2.47.tar.gz 1161675 BLAKE2B 8491d5f977b9e23071098016443e8384bc584b8b1160e84b725a2965d032d8b8f5a7ac8b16b1a1e62d808b0543650e0bc42ddc52806c5475a7ca9e26640e84aa SHA512 c9607990a1cf947f9cf294f818d9c6de314dca92a9f106dc65e8d0fdeb6ac91b21a394c711c4b8aabae33b60fc70b72dc9483b6ac48d4e3be3019501ebc26332
diff --git a/app-shells/yash/metadata.xml b/app-shells/yash/metadata.xml
new file mode 100644
index 00000000000..106f4c845b2
--- /dev/null
+++ b/app-shells/yash/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Yash, yet another shell, is a POSIX-compliant command line shell
+ written in C99 (ISO/IEC 9899:1999). Yash is intended to be the most
+ POSIX-compliant shell in the world while supporting features for daily
+ interactive and scripting use. Notable features are:
+
+ * Global aliases
+ * Arrays
+ * Socket redirection, pipeline redirection, and process redirection
+ * Brace expansion and extended globbing
+ * Fractional numbers in arithmetic expansion
+ * Prompt command and command-not-found handler
+ * Command line completion with predefined completion scripts for more than 100 commands
+ * Command line prediction based on command history
+ </longdescription>
+ <upstream>
+ <remote-id type="github">magicant/yash</remote-id>
+ <remote-id type="sourceforge-jp">yash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/yash/yash-2.47.ebuild b/app-shells/yash/yash-2.47.ebuild
new file mode 100644
index 00000000000..475398b4442
--- /dev/null
+++ b/app-shells/yash/yash-2.47.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PLOCALES="en ja"
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osnd.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/69353/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}