summaryrefslogtreecommitdiff
path: root/app-vim/notes
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/notes')
-rw-r--r--app-vim/notes/Manifest2
-rw-r--r--app-vim/notes/metadata.xml8
-rw-r--r--app-vim/notes/notes-0.29.ebuild30
-rw-r--r--app-vim/notes/notes-0.33.ebuild30
4 files changed, 70 insertions, 0 deletions
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
new file mode 100644
index 00000000000..bf900ee6ad2
--- /dev/null
+++ b/app-vim/notes/Manifest
@@ -0,0 +1,2 @@
+DIST notes-0.29.tar.gz 53079 SHA256 231ad897f7a89067a7ec05366e2bd4782faad1b0abb198b241821c66612ae258 SHA512 9f757f06c9d881cd880ba7d9d0b5c6ab466f511d6a09919dc4febf9fa23132a3f7cf8e9d6f3b548ae94444fa3083e7f88f8d7a8a385cdccdb627e496f6cfefab WHIRLPOOL 230e1855ddc6512d4bee14524b2cab09d01ece02b6898d49054ca8e071ebf5cdd8e4dc17be5dbe459f5879e8b5539847eaa6932b252fb6f39b625a4f2d2b8d85
+DIST notes-0.33.tar.gz 238638 SHA256 f4ca53d17d2e103eccfdeb8fcaf0ad47b02c594ca2587ae5b95fd7ac33407a1e SHA512 0149c12e5feeeaaeca658dd8136ad590694a06f367ef227aad786bc830254acf74903edf2334527274dcdfaff7cd86e605c2ea083a5ec09d4409d5b4fef194f1 WHIRLPOOL a14a65d37c5630c8dcccc4a7620ff679302c07cad05a3baa57a322f75d88199ed73fc70026a1674817a8d20a4e8ed87f3c6b6a9bc32419d508f1024522868be8
diff --git a/app-vim/notes/metadata.xml b/app-vim/notes/metadata.xml
new file mode 100644
index 00000000000..309e5993382
--- /dev/null
+++ b/app-vim/notes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">xolox/vim-notes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/notes/notes-0.29.ebuild b/app-vim/notes/notes-0.29.ebuild
new file mode 100644
index 00000000000..dfc1aeaffa4
--- /dev/null
+++ b/app-vim/notes/notes-0.29.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: easy note taking in vim"
+HOMEPAGE="http://peterodding.com/code/vim/notes/"
+SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.16.1"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+
+ python_fix_shebang .
+}
diff --git a/app-vim/notes/notes-0.33.ebuild b/app-vim/notes/notes-0.33.ebuild
new file mode 100644
index 00000000000..06a63c0a2f6
--- /dev/null
+++ b/app-vim/notes/notes-0.33.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: easy note taking in vim"
+HOMEPAGE="http://peterodding.com/code/vim/notes/"
+SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.17.6"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+
+ python_fix_shebang .
+}