summaryrefslogtreecommitdiff
path: root/app-vim/tcomment/tcomment-3.08.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/tcomment/tcomment-3.08.1.ebuild')
-rw-r--r--app-vim/tcomment/tcomment-3.08.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/tcomment/tcomment-3.08.1.ebuild b/app-vim/tcomment/tcomment-3.08.1.ebuild
new file mode 100644
index 00000000000..ab0decbf1e3
--- /dev/null
+++ b/app-vim/tcomment/tcomment-3.08.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tomtom/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+LICENSE="GPL-3"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r README LICENSE.TXT etc spec addon* || die
+}