summaryrefslogtreecommitdiff
path: root/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libassa/libassa-3.5.1-r1.ebuild')
-rw-r--r--dev-cpp/libassa/libassa-3.5.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/libassa/libassa-3.5.1-r1.ebuild b/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
new file mode 100644
index 00000000000..f198f3c2cad
--- /dev/null
+++ b/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A networking library based on Adaptive Communication Patterns"
+HOMEPAGE="http://libassa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
+}