summaryrefslogtreecommitdiff
path: root/dev-db/cpp-driver/cpp-driver-2.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/cpp-driver/cpp-driver-2.4.3.ebuild')
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.4.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/cpp-driver-2.4.3.ebuild b/dev-db/cpp-driver/cpp-driver-2.4.3.ebuild
new file mode 100644
index 00000000000..c30a890a08a
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="http://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/libuv
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}