summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-10.0.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-10.0.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-db/postgresql/postgresql-10.0.ebuild b/dev-db/postgresql/postgresql-10.0.ebuild
index f8c09bb804c..c3b086316a3 100644
--- a/dev-db/postgresql/postgresql-10.0.ebuild
+++ b/dev-db/postgresql/postgresql-10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -21,21 +21,17 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="http://www.postgresql.org/"
-LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN
- zh_TW"
IUSE="doc kerberos kernel_linux ldap libressl nls pam perl python +readline
selinux +server systemd ssl static-libs tcl threads uuid xml zlib"
-
-for lingua in ${LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
wanted_languages() {
- local enable_langs
+ local linguas="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru
+ sk sl sv tr zh_CN zh_TW"
+ local enable_langs lingua
- for lingua in ${LINGUAS} ; do
- use linguas_${lingua} && enable_langs+="${lingua} "
+ for lingua in ${linguas} ; do
+ has ${lingua} ${LINGUAS-${lingua}} && enable_langs+="${lingua} "
done
echo -n ${enable_langs}