summaryrefslogtreecommitdiff
path: root/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild')
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild b/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild
new file mode 100644
index 00000000000..1b84488b876
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}