summaryrefslogtreecommitdiff
path: root/dev-dotnet/xsp/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/xsp/files')
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd6
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server.confd2
-rw-r--r--dev-dotnet/xsp/files/2.2/mod-mono-server.initd81
-rw-r--r--dev-dotnet/xsp/files/2.2/xsp.confd2
-rw-r--r--dev-dotnet/xsp/files/2.2/xsp.initd4
-rw-r--r--dev-dotnet/xsp/files/aclocal-fix.patch13
6 files changed, 101 insertions, 7 deletions
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd b/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
index 6fda67726d8..6ce6a60bcec 100644
--- a/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
+++ b/dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Id: mod-mono-server-r1.initd,v 1.1 2012/01/22 12:54:29 pacho Exp $
depend() {
use net
@@ -58,7 +58,7 @@ start() {
return 1
fi
- MONO_SHARED_DIR=/tmp ; export MONO_SHARED_DIR
+ export MONO_SHARED_DIR=/tmp
ebegin "Starting mod-mono-server"
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server.confd b/dev-dotnet/xsp/files/2.2/mod-mono-server.confd
index dbc5c4cf20c..7cefdbea49b 100644
--- a/dev-dotnet/xsp/files/2.2/mod-mono-server.confd
+++ b/dev-dotnet/xsp/files/2.2/mod-mono-server.confd
@@ -1,5 +1,5 @@
# Config file for /etc/init.d/mod-mono-server
-# $Id$
+# $Id: mod-mono-server.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
# Configuration directives for mod-mono-server.exe. For more information on
# these variables, see the man page for xsp(1).
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server.initd b/dev-dotnet/xsp/files/2.2/mod-mono-server.initd
new file mode 100644
index 00000000000..49119e5af49
--- /dev/null
+++ b/dev-dotnet/xsp/files/2.2/mod-mono-server.initd
@@ -0,0 +1,81 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: mod-mono-server.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
+
+depend() {
+ use net
+ after dotnet
+}
+
+start() {
+ [ -z "$MonoServerRootDir" ] && \
+ MonoServerRootDir="/usr/lib/xsp/test"
+ [ -z "$MonoApplications" ] && \
+ MonoApplications="/mono:/usr/lib/xsp/test,/:."
+ [ -z "$UnixSocketFileName" ] && \
+ UnixSocketFileName="/tmp/mod_mono_server"
+ [ -z "$MonoServerAddress" ] && \
+ MonoServerAddress=127.0.0.1
+ [ -z "$MonoServerPort" ] && \
+ MonoServerPort=8080
+ [ -z "$MonoServerVersion" ] && \
+ MonoServerVersion=1
+
+ MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
+--applications ${MonoApplications} --nonstop"
+
+ [ -n "$MonoApplicationsConfigDir" ] && \
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--appconfigdir ${MonoApplicationsConfigDir}"
+
+ case "$MonoServerChannel" in
+ "tcp" )
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--address ${MonoServerAddress} --port ${MonoServerPort}"
+ ;;
+
+ "unix" )
+ [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--filename ${UnixSocketFileName}"
+ ;;
+
+ * )
+ eerror "Please set a valid value for MonoServerChannel"
+ return 1
+ ;;
+ esac
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ modmonoserverpath=1.0/mod-mono-server.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ modmonoserverpath=2.0/mod-mono-server2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
+ return 1
+ fi
+
+ export MONO_SHARED_DIR=/tmp
+
+ ebegin "Starting mod-mono-server"
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/mod-mono-server.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
+ -- $MONO_SERVER_OPTS
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mod-mono-server"
+
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/mod-mono-server.pid
+
+ eend $?
+}
diff --git a/dev-dotnet/xsp/files/2.2/xsp.confd b/dev-dotnet/xsp/files/2.2/xsp.confd
index 1004e7428fa..45a79a52bb6 100644
--- a/dev-dotnet/xsp/files/2.2/xsp.confd
+++ b/dev-dotnet/xsp/files/2.2/xsp.confd
@@ -1,5 +1,5 @@
# Config file for /etc/init.d/xsp
-# $Id$
+# $Id: xsp.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
# This is the document root; trailing slash is not necessary
MonoServerRoot=/usr/lib/xsp/test
diff --git a/dev-dotnet/xsp/files/2.2/xsp.initd b/dev-dotnet/xsp/files/2.2/xsp.initd
index 5b609580ebf..0432bca7d36 100644
--- a/dev-dotnet/xsp/files/2.2/xsp.initd
+++ b/dev-dotnet/xsp/files/2.2/xsp.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Id: xsp.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
depend() {
need net
diff --git a/dev-dotnet/xsp/files/aclocal-fix.patch b/dev-dotnet/xsp/files/aclocal-fix.patch
new file mode 100644
index 00000000000..49a00050fe8
--- /dev/null
+++ b/dev-dotnet/xsp/files/aclocal-fix.patch
@@ -0,0 +1,13 @@
+--- Makefile_old.am 2013-07-30 09:11:50.033962122 +0400
++++ Makefile.am 2013-07-30 09:12:20.843574793 +0400
+@@ -1,10 +1,2 @@
+ SUBDIRS=build man src test tools scripts packaging lib
+ ACLOCAL_AMFLAGS += -I build/m4
+-
+-if UNITTESTS
+-SUBDIRS += unittests
+-endif
+-
+-if BUILD_DOCS
+-SUBDIRS += docs
+-endif