summaryrefslogtreecommitdiff
path: root/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild')
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
new file mode 100644
index 00000000000..8ea5793b5cd
--- /dev/null
+++ b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/queue
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Fast golang queue using ring-buffer"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}