summaryrefslogtreecommitdiff
path: root/dev-haskell/drift
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/drift')
-rw-r--r--dev-haskell/drift/Manifest3
-rw-r--r--dev-haskell/drift/drift-2.2.0.ebuild33
-rw-r--r--dev-haskell/drift/drift-2.2.3.ebuild36
-rw-r--r--dev-haskell/drift/drift-2.4.2.ebuild35
-rw-r--r--dev-haskell/drift/files/drift-2.2.3-ghc-7.4.patch13
-rw-r--r--dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch22
-rw-r--r--dev-haskell/drift/metadata.xml8
7 files changed, 150 insertions, 0 deletions
diff --git a/dev-haskell/drift/Manifest b/dev-haskell/drift/Manifest
new file mode 100644
index 00000000000..4526657ac4f
--- /dev/null
+++ b/dev-haskell/drift/Manifest
@@ -0,0 +1,3 @@
+DIST DrIFT-2.2.0.tar.gz 252043 SHA256 ae24a61a4ca2f81e9f033ce6cc08b2f5f5239de11c53aa677b3de62da4f97406 SHA512 6aad118b53b241a872457345510343c537e7ff3520eb06deaef57aa1296a6cea1f0baa03107d70967429770fc61872834e4e60f1d5f138f3d4e302b2b864d82d WHIRLPOOL c31d683cb100e416663125c816d11c7dcba4982fbe60ab9c3c30187c141233c37a8bb1588fffc2dc9a0a145f875e310456176c224b831b3efb68dcf18c4532fd
+DIST DrIFT-2.2.3.tar.gz 219321 SHA256 c5edb6e89e3a04aa7918acd2db37413ff80f945fdd1370f3614dc0d93e8913a9 SHA512 e1291e61bf55d15aa291fcb62eed545be16530c8e69d21fdb9cc23dab2a00b54cba3e3a056acb5240cf0e16b7152626beda2c79d783c2db7c9a0bd707d5c36f2 WHIRLPOOL 74d08f1a2cdd232d3befd6192eaba1fabdd85f113e6a5c89dd2d85af35040c9c52399c3d9ef6940b9a9cd6cd91fd2ed261556af54fc3d66d8fce91f0edc10315
+DIST DrIFT-2.4.2.tar.gz 69676 SHA256 742a0b12f16a9da215a29c8284ae379734a70e7811a5f4b1a02dba2873751cf0 SHA512 c6f36e9efad171c165ea8028b7d251e66d5b410aaa51a74e4b8745cf76b77fcfdf6f641fd375f15663b559ae6b8939622a175ba321537afdbb2a114a1550f7db WHIRLPOOL fb064113e4d9fe1f38a59a2c45b561346b5a54748c96b0615b1d09537ce30f8341762d9a825dedbbcff5ff9bf3fe880506e48ba32dfe7318e56828b253fd0ae7
diff --git a/dev-haskell/drift/drift-2.2.0.ebuild b/dev-haskell/drift/drift-2.2.0.ebuild
new file mode 100644
index 00000000000..8ec2f59cb81
--- /dev/null
+++ b/dev-haskell/drift/drift-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit ghc-package
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Preprocessor for automatic derivation of Haskell class instances"
+HOMEPAGE="http://repetae.net/john/computer/haskell/DrIFT/"
+SRC_URI="http://repetae.net/john/computer/haskell/DrIFT/drop/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --with-hc="$(ghc-getghc)" || die "configure failed"
+ # Makefile has no parallelism
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/dev-haskell/drift/drift-2.2.3.ebuild b/dev-haskell/drift/drift-2.2.3.ebuild
new file mode 100644
index 00000000000..ef4bb38730e
--- /dev/null
+++ b/dev-haskell/drift/drift-2.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base ghc-package
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Preprocessor for automatic derivation of Haskell class instances"
+HOMEPAGE="http://repetae.net/john/computer/haskell/DrIFT/"
+SRC_URI="http://repetae.net/john/computer/haskell/DrIFT/drop/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.2.3-ghc-7.4.patch)
+
+src_configure() {
+ econf --with-hc="$(ghc-getghc)" --with-hcflags="${HCFLAGS} -package haskell98 -hide-package base"
+}
+
+src_compile() {
+ # Makefile has no parallelism
+ emake -j1
+}
diff --git a/dev-haskell/drift/drift-2.4.2.ebuild b/dev-haskell/drift/drift-2.4.2.ebuild
new file mode 100644
index 00000000000..ed93cde8640
--- /dev/null
+++ b/dev-haskell/drift/drift-2.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="DrIFT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Program to derive type class instances"
+HOMEPAGE="http://repetae.net/computer/haskell/DrIFT/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
diff --git a/dev-haskell/drift/files/drift-2.2.3-ghc-7.4.patch b/dev-haskell/drift/files/drift-2.2.3-ghc-7.4.patch
new file mode 100644
index 00000000000..a7c1f3b5f7a
--- /dev/null
+++ b/dev-haskell/drift/files/drift-2.2.3-ghc-7.4.patch
@@ -0,0 +1,13 @@
+diff --git a/src/GenUtil.hs b/src/GenUtil.hs
+index 4855618..db416ed 100644
+--- a/src/GenUtil.hs
++++ b/src/GenUtil.hs
+@@ -482,7 +482,7 @@ overlaps :: Ord a => (a,a) -> (a,a) -> Bool
+ _ `overlaps` _ = True
+
+ -- | translate a number of seconds to a string representing the duration expressed.
+-showDuration :: Integral a => a -> String
++showDuration :: (Integral a, Show a) => a -> String
+ showDuration x = st "d" dayI ++ st "h" hourI ++ st "m" minI ++ show secI ++ "s" where
+ (dayI, hourI) = divMod hourI' 24
+ (hourI', minI) = divMod minI' 60
diff --git a/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch b/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch
new file mode 100644
index 00000000000..c45a2945fd2
--- /dev/null
+++ b/dev-haskell/drift/files/drift-2.4.2-ghc-7.10.patch
@@ -0,0 +1,22 @@
+diff --git a/src/ParseLib2.hs b/src/ParseLib2.hs
+index 730e4be..a7406fa 100644
+--- a/src/ParseLib2.hs
++++ b/src/ParseLib2.hs
+@@ -34,2 +34,3 @@ module ParseLib2
+ import Data.Char
++import Control.Applicative hiding ( many )
+ import Control.Monad
+@@ -49,2 +50,6 @@ instance Functor Parser where
+
++instance Applicative Parser where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Parser where
+@@ -58,2 +63,6 @@ instance Monad Parser where
+
++instance Alternative Parser where
++ (<|>) = mplus
++ empty = mzero
++
+ instance MonadPlus Parser where
diff --git a/dev-haskell/drift/metadata.xml b/dev-haskell/drift/metadata.xml
new file mode 100644
index 00000000000..8c66906af53
--- /dev/null
+++ b/dev-haskell/drift/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>