summaryrefslogtreecommitdiff
path: root/dev-haskell/project-template/project-template-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/project-template/project-template-0.2.0.ebuild')
-rw-r--r--dev-haskell/project-template/project-template-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/project-template/project-template-0.2.0.ebuild b/dev-haskell/project-template/project-template-0.2.0.ebuild
new file mode 100644
index 00000000000..fe658b9f7b6
--- /dev/null
+++ b/dev-haskell/project-template/project-template-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Specify Haskell project templates and generate files"
+HOMEPAGE="https://github.com/fpco/haskell-ide"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"