summaryrefslogtreecommitdiff
path: root/dev-haskell/statevar/statevar-1.1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/statevar/statevar-1.1.0.1.ebuild')
-rw-r--r--dev-haskell/statevar/statevar-1.1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/statevar/statevar-1.1.0.1.ebuild b/dev-haskell/statevar/statevar-1.1.0.1.ebuild
new file mode 100644
index 00000000000..f91113fd6c0
--- /dev/null
+++ b/dev-haskell/statevar/statevar-1.1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="StateVar"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="State variables"
+HOMEPAGE="https://github.com/haskell-opengl/StateVar"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.0:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"