summaryrefslogtreecommitdiff
path: root/dev-java/gson/gson-2.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/gson/gson-2.6.2.ebuild')
-rw-r--r--dev-java/gson/gson-2.6.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/gson/gson-2.6.2.ebuild b/dev-java/gson/gson-2.6.2.ebuild
new file mode 100644
index 00000000000..d20579bf277
--- /dev/null
+++ b/dev-java/gson/gson-2.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}-parent-${PV}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to convert JSON to Java objects and vice-versa"
+HOMEPAGE="https://github.com/google/gson"
+SRC_URI="https://github.com/google/${PN}/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${PN}/src/main/java"