summaryrefslogtreecommitdiff
path: root/dev-java/guava/guava-13.0.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/guava/guava-13.0.1-r3.ebuild')
-rw-r--r--dev-java/guava/guava-13.0.1-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/guava/guava-13.0.1-r3.ebuild b/dev-java/guava/guava-13.0.1-r3.ebuild
new file mode 100644
index 00000000000..b29b74c5cd6
--- /dev/null
+++ b/dev-java/guava/guava-13.0.1-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://code.google.com/p/guava-libraries/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="13"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+DEPEND="
+ dev-java/jsr305:0
+ java-virtuals/jdk-with-com-sun:0"
+RDEPEND="${DEPEND}
+ virtual/jre:1.7"
+DEPEND="${DEPEND}
+ app-arch/unzip
+ virtual/jdk:1.7" # https://github.com/google/guava/issues/1738
+JAVA_GENTOO_CLASSPATH="jsr305"