summaryrefslogtreecommitdiff
path: root/dev-java/guava/guava-17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/guava/guava-17.0.ebuild')
-rw-r--r--dev-java/guava/guava-17.0.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-java/guava/guava-17.0.ebuild b/dev-java/guava/guava-17.0.ebuild
deleted file mode 100644
index 8ebfe1f7ca6..00000000000
--- a/dev-java/guava/guava-17.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A collection of Google's core Java libraries"
-HOMEPAGE="https://code.google.com/p/guava-libraries/"
-SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
-
-LICENSE="Apache-2.0"
-SLOT="17"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-CDEPEND="
- dev-java/javax-inject:0
- dev-java/jsr305:0
- java-virtuals/jdk-with-com-sun:0"
-RDEPEND="${CDEPEND}
- || ( virtual/jre:1.7 virtual/jre:1.6 )"
-DEPEND="${CDEPEND}
- app-arch/unzip
- virtual/jdk:1.7" # https://code.google.com/p/guava-libraries/issues/detail?id=635
-
-JAVA_GENTOO_CLASSPATH="jsr305,javax-inject"