summaryrefslogtreecommitdiff
path: root/dev-libs/apr/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/apr/files')
-rw-r--r--dev-libs/apr/files/apr-1.5.0-cross-types.patch63
-rw-r--r--dev-libs/apr/files/apr-1.5.0-libtool.patch17
-rw-r--r--dev-libs/apr/files/apr-1.5.0-mint.patch22
-rw-r--r--dev-libs/apr/files/apr-1.5.0-sysroot.patch37
-rw-r--r--dev-libs/apr/files/apr-1.5.1-parallel_make_install.patch19
-rw-r--r--dev-libs/apr/files/config.layout.patch25
6 files changed, 183 insertions, 0 deletions
diff --git a/dev-libs/apr/files/apr-1.5.0-cross-types.patch b/dev-libs/apr/files/apr-1.5.0-cross-types.patch
new file mode 100644
index 00000000000..266e5676817
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.0-cross-types.patch
@@ -0,0 +1,63 @@
+use standard AC_CHECK_SIZEOF as it supports non-builtin types and
+supports cross-compiling sanely
+
+https://issues.apache.org/bugzilla/show_bug.cgi?id=56053
+
+--- a/configure.in
++++ b/configure.in
+@@ -1684,7 +1684,7 @@ else
+ socklen_t_value="int"
+ fi
+
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], pid_t, 8)
++AC_CHECK_SIZEOF(pid_t)
+
+ if test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_short"; then
+ pid_t_fmt='#define APR_PID_T_FMT "hd"'
+@@ -1753,7 +1753,7 @@ APR_CHECK_TYPES_COMPATIBLE(ssize_t, long, [ssize_t_fmt="ld"])
+ APR_CHECK_TYPES_COMPATIBLE(size_t, unsigned int, [size_t_fmt="u"])
+ APR_CHECK_TYPES_COMPATIBLE(size_t, unsigned long, [size_t_fmt="lu"])
+
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], ssize_t, 8)
++AC_CHECK_SIZEOF(ssize_t)
+
+ AC_MSG_CHECKING([which format to use for apr_ssize_t])
+ if test -n "$ssize_t_fmt"; then
+@@ -1770,7 +1770,7 @@ fi
+
+ ssize_t_fmt="#define APR_SSIZE_T_FMT \"$ssize_t_fmt\""
+
+-APR_CHECK_SIZEOF_EXTENDED([#include <stddef.h>], size_t, 8)
++AC_CHECK_SIZEOF(size_t)
+
+ AC_MSG_CHECKING([which format to use for apr_size_t])
+ if test -n "$size_t_fmt"; then
+@@ -1787,7 +1787,7 @@ fi
+
+ size_t_fmt="#define APR_SIZE_T_FMT \"$size_t_fmt\""
+
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], off_t, 8)
++AC_CHECK_SIZEOF(off_t)
+
+ if test "${ac_cv_sizeof_off_t}${apr_cv_use_lfs64}" = "4yes"; then
+ # Enable LFS
+@@ -1866,7 +1866,7 @@ case $host in
+ ;;
+ *)
+ ino_t_value=ino_t
+- APR_CHECK_SIZEOF_EXTENDED(AC_INCLUDES_DEFAULT, ino_t, $ac_cv_sizeof_long)
++ AC_CHECK_SIZEOF(ino_t)
+ if test $ac_cv_sizeof_ino_t = 4; then
+ if test $ac_cv_sizeof_long = 4; then
+ ino_t_value="unsigned long"
+@@ -1886,8 +1886,8 @@ else
+ bigendian=0
+ fi
+
+-APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>
+-#include <sys/uio.h>],struct iovec,0)
++AC_CHECK_SIZEOF(struct iovec,,[AC_INCLUDES_DEFAULT
++#include <sys/uio.h>])
+ if test "$ac_cv_sizeof_struct_iovec" = "0"; then
+ have_iovec=0
+ else
diff --git a/dev-libs/apr/files/apr-1.5.0-libtool.patch b/dev-libs/apr/files/apr-1.5.0-libtool.patch
new file mode 100644
index 00000000000..5368a2689bd
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.0-libtool.patch
@@ -0,0 +1,17 @@
+generate a local copy of libtool for use in compiling
+
+https://bugs.gentoo.org/374355
+
+--- a/configure.in
++++ b/configure.in
+@@ -260,9 +260,7 @@ case $host in
+ fi
+ else
+ dnl libtoolize requires that the following not be indented
+- dnl should become LT_INIT(win32-dll)
+-AC_LIBTOOL_WIN32_DLL
+-AC_PROG_LIBTOOL
++LT_INIT(win32-dll)
+ # get libtool's setting of shlibpath_var
+ eval `grep "^shlibpath_var=[[A-Z_]]*$" $apr_builddir/libtool`
+ if test "x$shlibpath_var" = "x"; then
diff --git a/dev-libs/apr/files/apr-1.5.0-mint.patch b/dev-libs/apr/files/apr-1.5.0-mint.patch
new file mode 100644
index 00000000000..cfe039e962c
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.0-mint.patch
@@ -0,0 +1,22 @@
+--- apr-1.5.0/build/apr_hints.m4
++++ apr-1.5.0/build/apr_hints.m4
+@@ -45,6 +45,8 @@
+ case "$host" in
+ *mint)
+ APR_ADDTO(CPPFLAGS, [-DMINT -D_GNU_SOURCE])
++ apr_cv_pthreads_cflags="none"
++ apr_cv_pthreads_lib="-lpthread"
+ ;;
+ *MPE/iX*)
+ APR_ADDTO(CPPFLAGS, [-DMPE -D_POSIX_SOURCE -D_SOCKET_SOURCE])
+--- apr-1.5.0/build/apr_threads.m4
++++ apr-1.5.0/build/apr_threads.m4
+@@ -198,7 +198,7 @@
+ AC_DEFUN([APR_CHECK_SIGWAIT_ONE_ARG], [
+ AC_CACHE_CHECK(whether sigwait takes one argument,ac_cv_sigwait_one_arg,[
+ AC_TRY_COMPILE([
+-#if defined(__NETBSD__) || defined(DARWIN)
++#if defined(__NETBSD__) || defined(DARWIN) || defined(MINT)
+ /* When using the unproven-pthreads package, we need to pull in this
+ * header to get a prototype for sigwait(). Else things will fail later
+ * on. XXX Should probably be fixed in the unproven-pthreads package.
diff --git a/dev-libs/apr/files/apr-1.5.0-sysroot.patch b/dev-libs/apr/files/apr-1.5.0-sysroot.patch
new file mode 100644
index 00000000000..54c9d649ef0
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.0-sysroot.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/385775
+
+utilize $SYSROOT to find the right includedir tree
+
+drop the -L/-R paths since we know our libdir is the standard path which
+the compiler already knows how to locate
+
+--- a/apr-config.in
++++ b/apr-config.in
+@@ -28,7 +28,7 @@ libdir="@libdir@"
+ datarootdir="@datadir@"
+ datadir="@datadir@"
+-installbuilddir="@installbuilddir@"
+-includedir="@includedir@"
++installbuilddir="${SYSROOT}@installbuilddir@"
++includedir="${SYSROOT}@includedir@"
+
+ CC="@CC@"
+ CPP="@CPP@"
+@@ -183,7 +183,7 @@ while test $# -gt 0; do
+ --link-ld)
+ if test "$location" = "installed"; then
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+- flags="$flags -L$libdir -l${APR_LIBNAME}"
++ flags="$flags -l${APR_LIBNAME}"
+ else
+ ### this surely can't work since the library is in .libs?
+ flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}"
+@@ -200,7 +200,7 @@ while test $# -gt 0; do
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+ # Since the user is specifying they are linking with libtool, we
+ # *know* that -R will be recognized by libtool.
+- flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}"
++ flags="$flags -l${APR_LIBNAME}"
+ else
+ flags="$flags $LA_FILE"
+ fi
diff --git a/dev-libs/apr/files/apr-1.5.1-parallel_make_install.patch b/dev-libs/apr/files/apr-1.5.1-parallel_make_install.patch
new file mode 100644
index 00000000000..a58a229c378
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.1-parallel_make_install.patch
@@ -0,0 +1,19 @@
+http://www.mail-archive.com/dev@apr.apache.org/msg25738.html
+
+--- apr-1.5.1/Makefile.in
++++ apr-1.5.1/Makefile.in
+@@ -129,11 +129,11 @@
+ etags:
+ etags `find . -name '*.[ch]'`
+
+-make_tools_dir:
++OBJECTS_gen_test_char = tools/gen_test_char.lo $(LOCAL_LIBS)
++tools/gen_test_char.lo: tools/gen_test_char.c
+ $(APR_MKDIR) tools
++ $(LT_COMPILE)
+
+-OBJECTS_gen_test_char = tools/gen_test_char.lo $(LOCAL_LIBS)
+-tools/gen_test_char.lo: make_tools_dir
+ tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
+ $(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
+
diff --git a/dev-libs/apr/files/config.layout.patch b/dev-libs/apr/files/config.layout.patch
new file mode 100644
index 00000000000..66fa868c0bb
--- /dev/null
+++ b/dev-libs/apr/files/config.layout.patch
@@ -0,0 +1,25 @@
+--- config.layout.orig 2006-07-06 21:44:41.000000000 -0700
++++ config.layout 2006-07-06 21:46:26.000000000 -0700
+@@ -229,3 +229,22 @@
+ infodir: ${exec_prefix}/share/info
+ libsuffix: -${APR_MAJOR_VERSION}
+ </Layout>
++
++# Gentoo layout
++<Layout gentoo>
++ prefix: /usr
++ exec_prefix: ${prefix}
++ bindir: ${exec_prefix}/bin
++ sbindir: ${exec_prefix}/bin
++ libdir: ${exec_prefix}/lib
++ libexecdir: ${exec_prefix}/modules
++ mandir: ${prefix}/man
++ sysconfdir: ${prefix}/conf
++ datadir: /usr/share/apr-${APR_MAJOR_VERSION}
++ installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
++ includedir: ${prefix}/include/apr-${APR_MAJOR_VERSION}
++ localstatedir: ${prefix}
++ libsuffix: -${APR_MAJOR_VERSION}
++</Layout>
++
++