summaryrefslogtreecommitdiff
path: root/dev-ml/biniou/biniou-1.0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/biniou/biniou-1.0.13.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.0.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.0.13.ebuild b/dev-ml/biniou/biniou-1.0.13.ebuild
new file mode 100644
index 00000000000..221435a1763
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ use ocamlopt && dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+}