summaryrefslogtreecommitdiff
path: root/dev-ml/bolt/bolt-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/bolt/bolt-1.4.ebuild')
-rw-r--r--dev-ml/bolt/bolt-1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/bolt/bolt-1.4.ebuild b/dev-ml/bolt/bolt-1.4.ebuild
new file mode 100644
index 00000000000..e7e9e060e5a
--- /dev/null
+++ b/dev-ml/bolt/bolt-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Logging tool for the Objective Caml language"
+HOMEPAGE="http://bolt.x9c.fr/"
+SRC_URI="http://bolt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sh configure
+}
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES FEATURES
+ use doc && dohtml ocamldoc/*
+}