summaryrefslogtreecommitdiff
path: root/dev-ml/calendar/calendar-2.03.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/calendar/calendar-2.03.2.ebuild')
-rw-r--r--dev-ml/calendar/calendar-2.03.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/calendar/calendar-2.03.2.ebuild b/dev-ml/calendar/calendar-2.03.2.ebuild
new file mode 100644
index 00000000000..29ac9ae075a
--- /dev/null
+++ b/dev-ml/calendar/calendar-2.03.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="An Ocaml library to handle dates and time"
+HOMEPAGE="http://forge.ocamlcore.org/projects/calendar/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/915/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES
+ use doc && dohtml -r doc
+}