summaryrefslogtreecommitdiff
path: root/dev-ml/easy-format/easy-format-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/easy-format/easy-format-1.0.2.ebuild')
-rw-r--r--dev-ml/easy-format/easy-format-1.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/easy-format/easy-format-1.0.2.ebuild b/dev-ml/easy-format/easy-format-1.0.2.ebuild
new file mode 100644
index 00000000000..1e8c7a889f5
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/easy-format.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}