summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild')
-rw-r--r--dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
new file mode 100644
index 00000000000..84098f18ecb
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Overlay over bigarrays of chars"
+HOMEPAGE="https://github.com/c-cube/ocaml-bigstring/"
+SRC_URI="https://github.com/c-cube/ocaml-bigstring/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# ocamlfind: Package `QTest2Lib' not found
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ test? ( dev-ml/iTeML )
+"
+
+src_install() {
+ findlib_src_preinst
+ default
+}