summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
new file mode 100644
index 00000000000..86eb3b52908
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://nodeload.github.com/vincenthz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}