summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlweb/ocamlweb-1.39.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlweb/ocamlweb-1.39.ebuild')
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.39.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocamlweb/ocamlweb-1.39.ebuild b/dev-ml/ocamlweb/ocamlweb-1.39.ebuild
new file mode 100644
index 00000000000..1c411c9d4aa
--- /dev/null
+++ b/dev-ml/ocamlweb/ocamlweb-1.39.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package eutils base
+
+DESCRIPTION="O'Caml literate programming tool"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.09:=
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.37-strip.patch"
+ )
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake UPDATETEX="" prefix="${D}/usr" MANDIR="${D}/usr/share/man" BASETEXDIR="${D}/${TEXMF}" install
+ dodoc README CHANGES
+}