summaryrefslogtreecommitdiff
path: root/dev-ml/pgocaml/pgocaml-1.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pgocaml/pgocaml-1.7.1.ebuild')
-rw-r--r--dev-ml/pgocaml/pgocaml-1.7.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/pgocaml/pgocaml-1.7.1.ebuild b/dev-ml/pgocaml/pgocaml-1.7.1.ebuild
new file mode 100644
index 00000000000..a48ef3813c3
--- /dev/null
+++ b/dev-ml/pgocaml/pgocaml-1.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="PG'OCaml is a set of OCaml bindings for the PostgreSQL database"
+HOMEPAGE="http://pgocaml.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1099/${P}.tgz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc batteries"
+
+DEPEND="dev-ml/calendar:=
+ >=dev-ml/batteries-2:=
+ dev-ml/csv:=
+ dev-ml/pcre-ocaml:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "CHANGELOG.txt"
+ "doc/BUGS.txt" "doc/CONTRIBUTORS.txt"
+ "doc/HOW_IT_WORKS.txt" "doc/PROFILING.txt"
+ )