summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild b/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
index 0caa4d7a3dc..1b7a8601f9d 100644
--- a/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
+++ b/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit findlib versionator
+inherit findlib versionator eutils
MY_PV=$(replace_version_separator 2 '+')
DESCRIPTION="Tools for authors of ppx rewriters"
@@ -20,6 +20,10 @@ DEPEND=">=dev-lang/ocaml-4.03.0:="
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-$(replace_version_separator 2 '-')"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.04_beta' && epatch "${FILESDIR}/ocaml404.patch"
+}
+
src_compile() {
emake -j1
}