summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/menhir/files/ocamlbuild.patch13
-rw-r--r--dev-ml/menhir/menhir-20151112.ebuild6
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-ml/menhir/files/ocamlbuild.patch b/dev-ml/menhir/files/ocamlbuild.patch
new file mode 100644
index 00000000000..6a8743f44b8
--- /dev/null
+++ b/dev-ml/menhir/files/ocamlbuild.patch
@@ -0,0 +1,13 @@
+Index: menhir-20151112/src/Makefile
+===================================================================
+--- menhir-20151112.orig/src/Makefile
++++ menhir-20151112/src/Makefile
+@@ -19,7 +19,7 @@ endif
+ # ----------------------------------------------------------------------------
+ # Ocamlbuild tool and settings.
+
+-OCAMLBUILD := ocamlbuild -classic-display -j 0 -cflags "-safe-string -bin-annot"
++OCAMLBUILD := ocamlbuild -no-hygiene -classic-display -j 0 -cflags "-safe-string -bin-annot"
+
+ # ----------------------------------------------------------------------------
+ # For everyday development.
diff --git a/dev-ml/menhir/menhir-20151112.ebuild b/dev-ml/menhir/menhir-20151112.ebuild
index 61fb1e2d35a..1b7e19d3034 100644
--- a/dev-ml/menhir/menhir-20151112.ebuild
+++ b/dev-ml/menhir/menhir-20151112.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit findlib
+inherit findlib eutils
DESCRIPTION="LR(1) parser generator for the OCaml language"
HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
@@ -19,6 +19,10 @@ RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
DEPEND="${RDEPEND}
dev-ml/ocamlbuild"
+src_prepare() {
+ epatch "${FILESDIR}/ocamlbuild.patch"
+}
+
src_configure() {
if ! use ocamlopt ; then
export TARGET=byte