summaryrefslogtreecommitdiff
path: root/dev-perl/ExtUtils-AutoInstall
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/ExtUtils-AutoInstall')
-rw-r--r--dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.630.0-r1.ebuild25
-rw-r--r--dev-perl/ExtUtils-AutoInstall/Manifest1
-rw-r--r--dev-perl/ExtUtils-AutoInstall/metadata.xml9
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.630.0-r1.ebuild b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.630.0-r1.ebuild
new file mode 100644
index 00000000000..dc45c628889
--- /dev/null
+++ b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.630.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=AUTRIJUS
+MODULE_VERSION=0.63
+inherit perl-module
+
+DESCRIPTION="Allows module writers to specify a more sophisticated form of dependency information"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+# TESTS BAD. Wants to write to cpan's config on the live system
+#SRC_TEST="do"
+
+RDEPEND="dev-perl/Sort-Versions"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ echo "n" | perl-module_src_compile
+}
diff --git a/dev-perl/ExtUtils-AutoInstall/Manifest b/dev-perl/ExtUtils-AutoInstall/Manifest
new file mode 100644
index 00000000000..7d2ee2edec9
--- /dev/null
+++ b/dev-perl/ExtUtils-AutoInstall/Manifest
@@ -0,0 +1 @@
+DIST ExtUtils-AutoInstall-0.63.tar.gz 26951 SHA256 829d4976e85d04dd18e24f500d03fb662e40aabf8609b633331b1925e0455299 SHA512 3836dbdd175732109c88a2c0e8d19929fbf59ef453c7149b6a6b6658cf419f241c91ba86fe7f4a1d7bf1af4d7ef42809e523f05e683e9bba75ca9aa9d47e1445 WHIRLPOOL 759e7802bb74821bb76d23ab1e554f70612f12487296ac27abc1c89a4911f99548866ebacfd29ecc1e23033a6ac7dd1697056afd7b2843a0c0b7d9c2cbb558bc
diff --git a/dev-perl/ExtUtils-AutoInstall/metadata.xml b/dev-perl/ExtUtils-AutoInstall/metadata.xml
new file mode 100644
index 00000000000..fdbe9a1ef06
--- /dev/null
+++ b/dev-perl/ExtUtils-AutoInstall/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">ExtUtils-AutoInstall</remote-id>
+ <remote-id type="cpan-module">ExtUtils::AutoInstall</remote-id>
+ </upstream>
+</pkgmetadata>