summaryrefslogtreecommitdiff
path: root/dev-perl/UUID/UUID-0.260.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/UUID/UUID-0.260.0.ebuild')
-rw-r--r--dev-perl/UUID/UUID-0.260.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/UUID/UUID-0.260.0.ebuild b/dev-perl/UUID/UUID-0.260.0.ebuild
new file mode 100644
index 00000000000..5a87b764da3
--- /dev/null
+++ b/dev-perl/UUID/UUID-0.260.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+DIST_AUTHOR=JRM
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Perl extension for using UUID interfaces as defined in e2fsprogs"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Note: UUID appears to link against a bunch of different UUID
+# implementations depending on availability and platform.
+#
+# Presently uses uuid.h/libuuid.so from util-linux which is fine for Linux
+# platforms, but may need special attention on *bsd, *osx and win*
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Devel-CheckLib-1.20.0
+"