summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild')
-rw-r--r--dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild b/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild
new file mode 100644
index 00000000000..59e96421399
--- /dev/null
+++ b/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP class to communicate with IRC networks"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+DOCS=( CREDITS FEATURES docs/HOWTO README.md )
+
+src_install() {
+ local HTML_DOCS=( )
+ use examples && HTML_DOCS+=( docs/examples/ )
+
+ if use doc; then
+ DOCS+=( docs/DOCUMENTATION )
+ HTML_DOCS+=( docs/HTML/* )
+ fi
+ php-pear-r2_src_install
+}