summaryrefslogtreecommitdiff
path: root/dev-php/phpdepend/phpdepend-2.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpdepend/phpdepend-2.2.2.ebuild')
-rw-r--r--dev-php/phpdepend/phpdepend-2.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/phpdepend/phpdepend-2.2.2.ebuild b/dev-php/phpdepend/phpdepend-2.2.2.ebuild
new file mode 100644
index 00000000000..284eb7ca982
--- /dev/null
+++ b/dev-php/phpdepend/phpdepend-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Static code analyser for PHP"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+HOMEPAGE="http://www.pdepend.org"
+SRC_URI="http://static.pdepend.org/php/${PV}/pdepend.phar -> ${P}.phar"
+
+RDEPEND=">=dev-lang/php-5.2.3:*[phar]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/${PN}
+}