summaryrefslogtreecommitdiff
path: root/dev-python/APScheduler/APScheduler-3.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/APScheduler/APScheduler-3.0.1.ebuild')
-rw-r--r--dev-python/APScheduler/APScheduler-3.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.0.1.ebuild b/dev-python/APScheduler/APScheduler-3.0.1.ebuild
new file mode 100644
index 00000000000..67ba8903d3b
--- /dev/null
+++ b/dev-python/APScheduler/APScheduler-3.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="In-process task scheduler with Cron-like capabilities"
+HOMEPAGE="https://bitbucket.org/agronholm/apscheduler"
+SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # Unsetting PYTHONPATH prevents a bunch of errors. I have no idea why.
+ unset PYTHONPATH
+ py.test || die "Testing failed with ${EPYTHON}"
+}