summaryrefslogtreecommitdiff
path: root/dev-python/RecSQL/RecSQL-0.7.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/RecSQL/RecSQL-0.7.8.ebuild')
-rw-r--r--dev-python/RecSQL/RecSQL-0.7.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/RecSQL/RecSQL-0.7.8.ebuild b/dev-python/RecSQL/RecSQL-0.7.8.ebuild
new file mode 100644
index 00000000000..258fe806fff
--- /dev/null
+++ b/dev-python/RecSQL/RecSQL-0.7.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/orbeckst/${PN}.git
+ https://github.com/orbeckst/${PN}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Simple SQL analysis of python records"
+HOMEPAGE="http://orbeckst.github.com/RecSQL/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"