summaryrefslogtreecommitdiff
path: root/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild')
-rw-r--r--dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild b/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild
new file mode 100644
index 00000000000..4664b1c5c31
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2015.2.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7)
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="http://saltstack.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND=">=dev-python/requests-2.4.2"
+RDEPEND="${DEPEND}"