summaryrefslogtreecommitdiff
path: root/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild')
-rw-r--r--dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild b/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild
new file mode 100644
index 00000000000..a287a9c465a
--- /dev/null
+++ b/dev-python/anyvc/anyvc-0.3.7.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to access any version control system"
+HOMEPAGE="http://pypi.python.org/pypi/anyvc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bazaar doc git mercurial subversion"
+
+RDEPEND="dev-python/apipkg[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-python/dulwich[${PYTHON_USEDEP}] )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-python/subvertpy )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/hgdistver[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# dev-python/hgdistver )"
+
+python_prepare_all() {
+ # Do not use unsupported theme options.
+ sed -e "/'tagline':/d" \
+ -e "/'bitbucket_project':/d" \
+ -i docs/conf.py
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html docs docs_output || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ pushd docs_output > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+ distutils-r1_python_install_all
+}