summaryrefslogtreecommitdiff
path: root/dev-python/argh/argh-0.26.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argh/argh-0.26.1.ebuild')
-rw-r--r--dev-python/argh/argh-0.26.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.26.1.ebuild b/dev-python/argh/argh-0.26.1.ebuild
new file mode 100644
index 00000000000..bce25c55204
--- /dev/null
+++ b/dev-python/argh/argh-0.26.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}